AliDropship plugin/add-ons PHP 5.6/7.0 support termination

Christina

Administrator
Staff member
#41
same problem. after follow all instructions, i got 500 error :-(
Hello, Abdul!

Change back PHP version (set the one that you've used before the upgrade) -> deactivate and delete AliDropship plugin and all AliDropship add-ons -> change PHP version to PHP 7.2 -> Download AliDropship plugin and add-ons archives for the updated PHP version -> Install -> Activate.

If you use Davinci, Michelangelo, Raphael or Rembrandt theme, there will be 500 error on site frontend when you remove the plugin, because these themes cannot work without AliDropship plugin. Once you install and activate AliDropship plugin again, website frontend will work correctly.
 

Med

New Member
#47
Okay guys, i got an update for you! If you are using php 7.2 version, for some reason increasing maximum file upload size won't work, so you have to upload the plugin via an FTP client. How do i know? Okay, i have 2 websites the first one is working with the Alidropship plugin and under php 7.2 version, I tried increasing maximum file upload size by editing the .htaccess file and that didn't work then tried editing the php.ini file and that didn't work either and then to the theme functions sections an added a few lines to fix the issue and that didn't work aswell, finally i contacted my web hosting provider and asked them to do it for me, So they did just that showed me screenshot but on my end the maximum file upload size was set to 2MB and would not change!
So what i did is i moved to my second website that runs under php 5.6 version and i tried each one of the solutions i mentioned above and guess what? each and every one of them worked properly!
So i think the problem is related to the php version, i don't know if the developers could agree with me on that! but atleast it's something you can think about.
You can try it by yourselves guys and tell me how everything went.
 
Last edited:

Sunster

Active Member
#48
Okay guys, i got an update for you! If you are using php 7.2 version, for some reason increasing maximum file upload size won't work, so you have to upload the plugin via an FTP client. How do i know? Okay, i have 2 websites the first one is working with the Alidropship plugin and under php 7.2 version, I tried increasing maximum file upload size by editing the .htaccess file and that didn't work then tried editing the php.ini file and that didn't work either and then to the theme functions sections an added a few lines to fix the issue and that didn't work aswell, finally i contacted my web hosting provider and asked them to do it for me, So they did just that showed me screenshot but on my end the maximum file upload size was set to 2MB and would not change!
So what i did is i moved to my second website that runs under php 5.6 version and i tried each one of the solutions i mentioned above and guess what? each and every one of them worked properly!
So i think the problem is related to the php version, i don't know if the developers could agree with me on that! but atleast it's something you can think about.
You can try it by yourselves guys and tell me how everything went.
No issues here changing the upload_max_filesize on php 7.2. And there are no restrictions/changes in php 7.2 that i know of. Must be something else.
 
#50
hye there..after consulting my hosting support, i manage to fully update my php and reinstall davinci and the alidropship for 7.2+ plugins successfully.
how ever, i got this error when i try to activate "customer gallery" add ons which i redownload from the links you gave in this forum thread.
kindly help.
i got other errors for dropship.me plugins too.
 

Attachments

#51
please help me. i got this following error after install abandoned cart add-on. I've install from your add-ons link

Error! You installed AliDropship Abandoned Cart plugin for PHP 5.6 - 7.0, but your version of PHP is 7.2.11. Please download and install AliDropship Abandoned Cart plugin for PHP 7.2.11 or change you PHP version from 7.2.11 to 5.6 - 7.0
 

Christina

Administrator
Staff member
#53
please help me. i got this following error after install abandoned cart add-on. I've install from your add-ons link

Error! You installed AliDropship Abandoned Cart plugin for PHP 5.6 - 7.0, but your version of PHP is 7.2.11. Please download and install AliDropship Abandoned Cart plugin for PHP 7.2.11 or change you PHP version from 7.2.11 to 5.6 - 7.0
Hello, Abdul!
You should go to our site -> add-ons -> Abandoned Cart -> Updates, enter your license key, select the right version of the add-on and download it.
 

Christina

Administrator
Staff member
#54
hye there..after consulting my hosting support, i manage to fully update my php and reinstall davinci and the alidropship for 7.2+ plugins successfully.
how ever, i got this error when i try to activate "customer gallery" add ons which i redownload from the links you gave in this forum thread.
kindly help.
i got other errors for dropship.me plugins too.
Hello, rocketdigital!
You should go to our site -> add-ons -> Customers Gallery -> Updates, enter your license key, select the right version of the add-on and download it.
 
#55
Hello, Abdul!
You should go to our site -> add-ons -> Abandoned Cart -> Updates, enter your license key, select the right version of the add-on and download it.
No thank you page or email received after put my email and licence key. Error from your site. However, i have received that abandoned cart zip file from our conversation (thanks to Eka).

Due to same happened to Customer Gallery add on, please send me the zip file (customer gallery for php 7.2 version) to my inbox or simply paste it here. Thanks
 

Yaros

Administrator
Staff member
#57
When I try to upgrade I get this error page so I can't add the plugin back. I also saw someone had stated that if we use Alihosting we don't need to do this. Is that true?
Have you removed all plugins and add-ons before upgrading to the new version of PHP? Downgrade it again, enter your WP-admin and check.
 
#59
I recently updated to PHP 7.1 and i followed all instructions but it is showing that my Ioncube loader is not installed but it is installed. I checked my phpinfo.php and the ioncube loader is active, can someone please help me!!!
 
#60
I recently updated to PHP 7.1 and i followed all instructions but it is showing that my Ioncube loader is not installed but it is installed. I checked my phpinfo.php and the ioncube loader is active, can someone please help me!!!
 

Attachments