AliDropship plugin/add-ons PHP 5.6/7.0 support termination

Victoria Kudryashova

Administrator
Staff member
#1
PHP 5.6/7.0 reached the end of its security support on December 3rd, 2017. Critical support will still be available through the end of 2018, but the PHP community no longer provides support for bugs or minor issues.

Upgrading to 7.1, 7.2 ensures the latest security updates are supported continuously by the community.

PHP 7.2 brings fresh updates including important security measures, new additions to the core, modern cryptography and faster load speed for sites.

PHP 7.2 runs 13% faster than 7.1 and 20% faster than 7.0.

We recommend updating to PHP 7.1 or to PHP 7.2 (best choice) right now.

Step 1:

Deactivate and delete AliDropship plugin and AliDropship add-ons. Don't worry: all your settings and products will be saved!

Step 2:

Change PHP version in cPanel:

Log in your hosting cPanel:

In your cPanel Software => MultiPHP Manager select your sites (arrow 3), choose a new PHP version (arrow 4) and press Apply button. Updates will be applied immediately.




If you don't have cPanel, contact your Hosting support and ask them to change PHP version.

Step 3:

Download AliDropship plugin and add-ons archives for the updated PHP version -> Install -> Activate:

https://alidropship.com/updates-plugin/

https://alidropship.com/addons/

Possible errors after upgrading to PHP 7.2:

1. 500 error

Why: you haven't deactivated and removed AliDropship plugin or AliDropship add-ons.

How to fix: change back PHP version (set the one that you've used before the upgrade) -> deactivate and delete AliDropship plugin and all AliDropship add-ons -> change PHP version to PHP 7.2 -> Download AliDropship plugin and add-ons archives for the updated PHP version -> Install -> Activate.

If you use Davinci, Michelangelo, Raphael or Rembrandt theme, there will be 500 error on site frontend when you remove the plugin, because these themes cannot work without AliDropship plugin. Once you install and activate AliDropship plugin again, website frontend will work correctly.

2. File cannot be decoded by this version of the ionCube Loader.



Why: your version of the ionCube Loader for PHP 7.2 is outdated.

How to fix: You need to contact your Hosting support and ask them to upgrade your ionCube version to the latest one for PHP 7.2 (not older than 10.2.4).

PHP SUPPORTED VERSIONS
 
Last edited:

Yaros

Administrator
Staff member
#4
My site is not responding. I did not do any changes you suggested. Is there anything to do with this?
It stopped working in the middle of the campaign.
We did not do any changes as well. It is just a recommendation to upgrade PHP version on your server. If you have issues with the server, please contact your hosting provider.
 
#5
We did not do any changes as well. It is just a recommendation to upgrade PHP version on your server. If you have issues with the server, please contact your hosting provider.[/QUOTE

I bought hosting from you. Somebody was doing something on the server. Anyway, it works now and I will follow your instructions. Let's see.
 
#8
hi Guys
I just updated the php by following the instructions specified by the admin and it all worked successfully. I think if you do that in order it is mentioned in the email sent by alidropship i am sure it will work fine.
thanks
 

Cam

New Member
#9
Fatal error: The file /home/........../public_html/wp-content/plugins/single-product-promo-page/core/core.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0
 
#12
PHP 5.6/7.0 reached the end of its security support on December 3rd, 2017. Critical support will still be available through the end of 2018, but the PHP community no longer provides support for bugs or minor issues.

Upgrading to 7.1, 7.2 ensures the latest security updates are supported continuously by the community.

PHP 7.2 brings fresh updates including important security measures, new additions to the core, modern cryptography and faster load speed for sites.

PHP 7.2 runs 13% faster than 7.1 and 20% faster than 7.0.

We recommend updating to PHP 7.1 or to PHP 7.2 (best choice) right now.

Step 1:

Deactivate and delete AliDropship plugin and AliDropship add-ons. Don't worry: all your settings and products will be saved!

Step 2:

Change PHP version in cPanel:

Log in your hosting cPanel:

In your cPanel Software => MultiPHP Manager select your sites (arrow 3), choose a new PHP version (arrow 4) and press Apply button. Updates will be applied immediately.




If you don't have cPanel, contact your Hosting support and ask them to change PHP version.

Step 3:

Download AliDropship plugin and add-ons archives for the updated PHP version -> Install -> Activate:

https://alidropship.com/updates-plugin/

https://alidropship.com/addons/

PHP SUPPORTED VERSIONS
why I can not install plugin alidropship 1.4.2?
always say like a screenshot Please try again.png
 
#13
updated successfully to php 7.2 in siteground webhosting. now my site is 3x faster :p

just a tip, don't talk to customer support in chat, they have limited technical support (learned from 1st hand experience)
if you encounter problem with ioncube loader, just open a ticket and let your web-hosting support install it for you.
make sure not to forget to set your php version to 7.2 and download the approximate plugin and add-on versions.
 

Christina

Administrator
Staff member
#16
If you use AliDropship hosting you don’t need to install ionCube loader because it is installed and enabled by default.

And I get this.
View attachment 6742
Hello, pero.vukobrat!

Indeed, ionCube loader is installed and enabled by default on our server.
Could you please PM me your domain name, WP login details and access for cPanel to check the issue? Thank you!
 

Ekaterina Sayapina

Administrator
Staff member
#19
Fatal error: The file /home/........../public_html/wp-content/plugins/single-product-promo-page/core/core.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0
Hello Cam,

Sent you a pm.