Facebook Pixel Enabled But Not Firing At any Event!

Med

New Member
#1
Hello there Ladies and gentlemen! i hope you are having a nice day.
Today i wanted to include a fb pixel to my website. So i created a new one, copied the Pixel ID then went to my website --> customization --> genaral and pasted it. I also installed Facebook Pixel Helper on my browser for troubleshooting. the problem is when i go to my website to check the events all what i can see is red errors. nothing is really working, not even a single event is firing! The pixel is activated but not firing at any event!
I've included 2 screenshots, The first one is what gets displayed on FB Pixel helper when i'm on my home page. The second one is when i click at any product. and please note that even when i add something to cart the red triangle doesn't go away.
Please reply to me as soon as possible, i'm really stuck.
 

Attachments

Med

New Member
#3
Hello ukdivision, Thanks for your reply! I just logged out from wp-admin and the problem still persists. Any other ideas? isn't here some developpers of the plugin that can tell me what's exactly going on?
 
#4
Hmm just did a check on mine using the helper and now mine is showing no pixel found :(

UPDATE: I tried removing the pixal ID from Customization - General tab and adding the code manually into the themes header.php file just before the closing head tag and pixal helper is showing my pixal.

I'm using the Divinci theme and PHP 7.2
 
Last edited:

Med

New Member
#5
I also tried the manual solution and pasted the whole pixel code in the header but that didn't work too. I'm also using the Davinvi theme but with php 5.6. I really hope one of the plugin developpers here could help me out. This is so frustrating. and thanks again ukdivision for your replies.
 
Top