Rubens homepage slider issue

#1
It is the 2nd picture, the middle one, in the slider that for some reason is not shown on mobile devices or being uploaded very slowly on some other devices.
All pictures on the page uploading perfectly ok, regardless of lazy-load mode.
It is happening only recently,
The picture is with the right dimensions and less than 100KB
www.mountainoteslcc.com
Any advice on this?
Thank you,
Shai
 

chris37

Well-Known Member
#2
It is the 2nd picture, the middle one, in the slider that for some reason is not shown on mobile devices or being uploaded very slowly on some other devices.
All pictures on the page uploading perfectly ok, regardless of lazy-load mode.
It is happening only recently,
The picture is with the right dimensions and less than 100KB
www.mountainoteslcc.com
Any advice on this?
Thank you,
Shai
The image is show normal in my mobile device... but the true is you must fix the loading speed of your website,is really slow
 
#3
The image is show normal in my mobile device... but the true is you must fix the loading speed of your website,is really slow
Thank you for your checking and your feedback. Appreciated.
I am not sure actually why it is slow currently, and most images pass also site compression and I am checking this.
Thanks again.
 

chris37

Well-Known Member
#4
Thank you for your checking and your feedback. Appreciated.
I am not sure actually why it is slow currently, and most images pass also site compression and I am checking this.
Thanks again.
Check your cached plugin setting,add cdn,

If nothing of the above not change the loading speed then change the hosting provider.
 
Top