PHP 7.2 and ioncube Fatal error

#1
Hi,

I'm hosted on a VPS.
Following Alidropship Woo plugin requirements I installed ioncube and activated ioncube. Since i'm on PHP 7.2 is installed ioncube for PHP 7.2.
When i try to activate the plugin I get this error :

Fatal error: The file /var/www/html/mydomain.com/wp-content/plugins/alidswoo/core/core.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

I tried to install and activate ioncube for PHP 5.6 but as you guessed it didn't work and i get this error when i execute php -v command :
# php -v
Failed loading /usr/lib/php/20170718/ioncube_loader_lin_5.6.so: /usr/lib/php/20170718/ioncube_loader_lin_5.6.so: undefined symbol: zend_block_interruptions
PHP 7.2.8-1+0~20180725124257.2+stretch~1.gbp571e56 (cli) (built: Jul 25 2018 12:43:00) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.2.8-1+0~20180725124257.2+stretch~1.gbp571e56, Copyright (c) 1999-2018, by Zend Technologies


Does you plugin can work on php 7.2 ?
I don't want to downgrade to php 7.0

Wordpress version : 4.9.8
PHP version : 7.2.5
ioncube for php 7.2
Theme : Flatsome 3.6.1

Thank you.
 
Last edited:

Mar

Moderator
#3
Hi,

I'm hosted on a VPS.
Following Alidropship Woo plugin requirements I installed ioncube and activated ioncube. Since i'm on PHP 7.2 is installed ioncube for PHP 7.2.
When i try to activate the plugin I get this error :

Fatal error: The file /var/www/html/mydomain.com/wp-content/plugins/alidswoo/core/core.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

I tried to install and activate ioncube for PHP 5.6 but as you guessed it didn't work and i get this error when i execute php -v command :
# php -v
Failed loading /usr/lib/php/20170718/ioncube_loader_lin_5.6.so: /usr/lib/php/20170718/ioncube_loader_lin_5.6.so: undefined symbol: zend_block_interruptions
PHP 7.2.8-1+0~20180725124257.2+stretch~1.gbp571e56 (cli) (built: Jul 25 2018 12:43:00) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.2.8-1+0~20180725124257.2+stretch~1.gbp571e56, Copyright (c) 1999-2018, by Zend Technologies


Does you plugin can work on php 7.2 ?
I don't want to downgrade to php 7.0

Wordpress version : 4.9.8
PHP version : 7.2.5
ioncube for php 7.2
Theme : Flatsome 3.6.1

Thank you.
You don't mention the plugin you installed, is it for PHP7.2?
 
Top