Hidden Images?

#1
I honestly didn't know whether I should post this under AliDropship Plug-In or WordPress. When I'm editing images inside of Wordpress using the AliDropship plugin to download the products, it seems as though some images that appear on my website, do not appear when you're editing the product. For example, at times there's an image that has Chinese writing on it that I would like to edit and get rid of. After editing all the images, that I see showing under the product, there will be images that will appear in the product on the website, where I have them for sale, that are not edited. Usually these images are identical to the ones I just edited, almost like copies of the originals, but I don't know where they're uploading from?
 

Mar

Moderator
#2
I honestly didn't know whether I should post this under AliDropship Plug-In or WordPress. When I'm editing images inside of Wordpress using the AliDropship plugin to download the products, it seems as though some images that appear on my website, do not appear when you're editing the product. For example, at times there's an image that has Chinese writing on it that I would like to edit and get rid of. After editing all the images, that I see showing under the product, there will be images that will appear in the product on the website, where I have them for sale, that are not edited. Usually these images are identical to the ones I just edited, almost like copies of the originals, but I don't know where they're uploading from?
Select an image in edit Visual tab. Without deselecting the image, switch to Text tab in the top right of the edit window. The highlighted codes are the image that is selected. You will see codes of images around it, some of it are images that you cannot see in Visual mode but is visible when you publish the product. The example below, the title image is selected. All codes above it can be deleted safely. Switch to Visual mode and you will see the images gone.


1566691519647.png

1566691758527.png
 
#4
So I checked it out and still have the problem. The only images I seem to see in the "text" screen are those showing in the "Visual" screen. However, once the product is published, I see other images that are only on the published website for the product that need some editing. I have no idea where they are being pulled from
 

Mar

Moderator
#5
So I checked it out and still have the problem. The only images I seem to see in the "text" screen are those showing in the "Visual" screen. However, once the product is published, I see other images that are only on the published website for the product that need some editing. I have no idea where they are being pulled from
I know what you are talking about. Everything is there in Text mode. You just don't see it. That product in my screenshots is an example of a product with images that only show when published, I removed it all successfully.
 
#7
So I went back and tried what you said, but there's still an issue.
I copied "all" the code under text tab and pasted it into a text editor. Then as I identified each image in the Visual Tab, I highlighted, in color, that portion of the text. My thought was that, anything starting with <img that was left must be the pictures, except nothing was left, all images were accounted for.

So there are a couple of things I also noticed:
  1. The Featured Image had to be edited, I was able to do this, but it did nothing on the website, I even dumped the cache and tried different browsers.
  2. The 3 other images I have besides the one in this post I noticed are all images you find on the AliExpress website for selecting optional colors. I’m referring to when you first open a product on AE, you see a picture and then you see the thumbnails for alternate colors that you can select. It’s these images that I need to edit, but they don’t “appear” to have downloaded into the plugin for editing. However, when I publish the product to my website, there they are, unedited.
 

Attachments

#9
Yes I did, as a test I edited a similar pair with a different finish and had the same thing happen. One thing I did notice is that, in using the Rubens theme, which I believe is one of their newer themes. It's the images you see on the left of the screen that I can't seem to access to edit. If you click on "Product Details" that's where you see the images I edited, some of these are the same images, but with my edits.

I considered maybe it's got something to do with the Theme, but that simply doesn't make sense to me. If my website is getting its images from what's in WordPress only, where the heck are they being stored in Wordpress?
 
#11
I'm going to check that out. Also, I'm attaching a picture where I tried a Preview of the Rembrandt theme, but same problem there to. It seems it's only these pictures that are in the thumbnails that I can't access to edit. I'm going ot check the directory you're referring to.

Cheers!
 

Attachments

Mar

Moderator
#15
So I went back and tried what you said, but there's still an issue.
I copied "all" the code under text tab and pasted it into a text editor. Then as I identified each image in the Visual Tab, I highlighted, in color, that portion of the text. My thought was that, anything starting with <img that was left must be the pictures, except nothing was left, all images were accounted for.

So there are a couple of things I also noticed:
  1. The Featured Image had to be edited, I was able to do this, but it did nothing on the website, I even dumped the cache and tried different browsers.
  2. The 3 other images I have besides the one in this post I noticed are all images you find on the AliExpress website for selecting optional colors. I’m referring to when you first open a product on AE, you see a picture and then you see the thumbnails for alternate colors that you can select. It’s these images that I need to edit, but they don’t “appear” to have downloaded into the plugin for editing. However, when I publish the product to my website, there they are, unedited.
You are talking about gallery images while I am talking about product description images as you can see in the screenshots. You cannot see the codes of gallery images in Text mode and you don't have to. So it is not the image that you cannot see in edit mode, but show when published. rather a part of an image you remove but still showing when published. This is a different story. Click on the gallery image in question in the front end, when it replace the main image, right click on the image, click on Open image in new tab. A new tab open with it's address in the server. As Direct Webstore said, it is in the file manager in cPanel.


1566745157565.png
 
#17
So I contacted SiteGround, who's hosting for me, and found out I didn't have the File Manager Tool. They installed it for me in CPanel and I'm now working on that.
 
#18
So I now have the File Manager Tool working, but still have the same problem.

I go to the CPanel and open the File Manager tool. I go to the public directory and select wp-content. I then select Upload and I see images.

Other than the images, like borders and such, I only see the images of products that I've alreay modified. These images seem to upload to the server, but the images I need I can't find for the life of me.

Is there any other directory where they could be stored?
 
#20
I think I know what's happening, the AliDropship plugin is pulling information from the AliExpress website to allow you to have the same kind of options a customer would get on their website. For example, if they had four or five different colours of an item, you would also have those options on your website. These seem to be images that are being imported from the AliExpress URL and are not showing as uploaded images in WordPress. It might be something I'm just going to have to live with.
 
Top