Updates

#1
I tried to update products by clicking on
Alidropship Woo > Settings > Updates

I am getting this error:

Updates
There has been a critical error on your website. Please check your site admin email inbox for instructions.

I checked the JS console, it reports the following error:

Failed to load resource: the server responded with a status of 500 () admin.php?page=adswaliupdates:1


± My site is currently on PHP version 7.4.8 (recently updated to this version)
± AliDropship Woo plug in Version 1.6.8 installed and activated.
± Woocommerce Version 4.3.1


What could be causing this issue?
 
#2
I reverted back to PHP version 7.2 on the server and now updates is working again.

I tried PHP version 7.3+ and 7.4+ it didn't work.

Please fix this feature in the future updates of the Alidropship Woo plug in to work with PHP version 7.3+ and 7.4+
 
#3
AliDropship only works with php7.2 in my experience (everything, not just product updates). This has been raised/requested in the past to make it compatible with more recent versions but I would expect that to take a while yet.

Hopefully it won't take too long as hosting companies tend to drop support for older php versions, although not 7.2 just yet.
 
#4
AliDropship only works with php7.2 in my experience (everything, not just product updates). This has been raised/requested in the past to make it compatible with more recent versions but I would expect that to take a while yet.

Hopefully it won't take too long as hosting companies tend to drop support for older php versions, although not 7.2 just yet.
Alidropship plugin and other add-ons except the Gift Box are compatible with PHP7.4. My sites were running with PHP7.4 in maybe a week. My host provider supported it including ionCube loader. It was running fine. The team promised to make Gift Box compatible with the PHP version but until now it don't happen. So today I set the sites back to PHP7.3.
 
#5
Alidropship plugin and other add-ons except the Gift Box are compatible with PHP7.4. My sites were running with PHP7.4 in maybe a week. My host provider supported it including ionCube loader. It was running fine. The team promised to make Gift Box compatible with the PHP version but until now it don't happen. So today I set the sites back to PHP7.3.
I've never been able to get it to work with anything after 7.2... and if I recall the docs say that as well, although it's been almost a month since I last tried.
 
#9
Think it is not supported by your host provider, yes, it is really no big deal.
It's definitely supported by them, it's actually the default when I add a new site (added one yesterday) I had to change it down to 7.2. I'll have another look at it in the future at some point when it becomes more urgent
 
#13
[QUOTE="Chrisschris37[/QUOTE]

I have got AliDropship Woo plug in Version 1.6.8 installed and activated. But I can't remember if it was the 7.1 or 7.2+ version. How can I find out which one I have?
 
#14
I raised my domain php version back to 7.4. The update now seems to work very sporadic. Sometimes it functions but for few products or directories. Sometimes nothing with an error message. I am still trying to get it to work as smooth as possible. Updating the products in inventory is crucial and I have it setup for once a week.
 
#15
I raised my domain php version back to 7.4. The update now seems to work very sporadic. Sometimes it functions but for few products or directories. Sometimes nothing with an error message. I am still trying to get it to work as smooth as possible. Updating the products in inventory is crucial and I have it setup for once a week.
Domain php what? Php is server programing language .

You proplem is not relate to php version. Because other user don't have the issue you say.
 
#17
I've never been able to get it to work with anything after 7.2
Alidropship plugin and other add-ons except the Gift Box are compatible with PHP7.4
Same here. All OK except for the Giftbox.
It didn't work for me, it had numerous issues when I updated php version and ioncube loader version.
Your host has possibly not installed ioncube for 7.4 yet. (Check via cPanel>Select PHP Version>Extensions. If it's not there, ask your host to install it. (then tick it/save). This goes for others here saying they have problems with 7.4. Maybe. ;)
 
Top