Product Images Upload Not Working

Mar

Moderator
#3
I am trying to upload all product images that are currently a link to Ali Express to my local site using the tool below, however, even after completion all my media are still showing as "External".
How about the three selected below, are they uploaded to the local site? You need to select including Product description images if you mean all product images.

1593225773068.png
 
#4
i don't have any product description images so i didn't select it. all other 3 images types still showing as external even after trying the upload a second time
 
Last edited:
#7
I suggest, should have button to reset images upload.
I don't think that's practical, as the only way would be to reset the product description to match AliExpress so you would lose any changes you made either before or after uploading them to the site. You should go through and set all the settings to what you want before importing. Admittedly it's easy to miss a setting or want to change something, but then you need a manual workaround or risk losing a lot of work.
 
#8
The options only apply the first time you import a product. Changing the options afterwards won't update existing products.

If you want to reimport a product you need to completely delete it (put in trash and then delete from trash) and then you can import it again from AliExpress with the new settings.

Unless you mean even after doing that it's still not importing them and they're still not showing in your media library?
What about the below instructions from Ali Knowledge article.. looks like you have this functionality its just not working...

1593466033863.png
 

Direct Webstore

Well-Known Member
#9
all my media are still showing as "External".
Did you check the image's URLs to check that they actually are external?
Did you try emptying the site cache and browser cache then checking again?

The options only apply the first time you import a product. Changing the options afterwards won't update existing products.
Incorrect. They are supposed to.

What about the below instructions from Ali Knowledge article.. looks like you have this functionality its just not working...
Looks like it ... and in that case, he should write to support@alidropship.com
 
#10
Yes I did they are all showing as external and it is causing a big problem when trying to optimize my site speed because some images loading from ali cdn and if i use a different cdn their images don't load and it becomes buggy..
 

Direct Webstore

Well-Known Member
#12
t is causing a big problem when trying to optimize my site speed because some images loading from ali cdn
Where the images are being served from doesn't make much difference regarding page loading speed in people's browsers. (It does a little). It's the size and amount of images that matter. And, more importantly, there are other factors that need to be considered for loading speed as well. I only download the featured image to my stores and the average loading time on pages is 2-4 seconds.

That's been discussed several times elsewhere in this forum, so I won't go into it again here.
 
#14
@Direct Webstore @TheDropMan Apologies - I've removed my post which had incorrect information, Direct Webstore is right and you'll need to wait to see what support say.

Regarding CDN and image loading, you should check your cache policies for images to make sure they're correct. It shouldn't make a difference if you're using the AliCDN as your own CDN should only try to serve images from your own domain. If you can utilize the AliCDN free of charge which is already globally distributed then it should be a bonus. I also use a CDN and use description images on the AliCDN. Also if you're not hosting the images on your domain they won't (depending on your host) count towards your bandwidth allocation if you have one.
 
Top