Problem with Stripe Payments ?

#1
I have set up a new site using Stripe (I have used Stripe with many sites so not new to this) , and on trying to put a test payment through have got the message

"Stripe no longer supports API requests made with TLS 1.0. Please initiate HTTPS connections with TLS 1.2 or later. You can learn more about this at https://stripe.com/blog/upgrading-tls." both on the site and through my Stripe portal"

Is the Alidropship payment system being updated with the requirements ? Kind of urgent ...
 
#2
After a bit of research it seems the issue lies with my server and Stripe deprecating some stuff, somehow have to figure out how to upgrade my server without destroying everything. I guess its just Paypal until then.
 

Vitaly Kukin

Administrator
Staff member
#5
I have set up a new site using Stripe (I have used Stripe with many sites so not new to this) , and on trying to put a test payment through have got the message

"Stripe no longer supports API requests made with TLS 1.0. Please initiate HTTPS connections with TLS 1.2 or later. You can learn more about this at https://stripe.com/blog/upgrading-tls." both on the site and through my Stripe portal"

Is the Alidropship payment system being updated with the requirements ? Kind of urgent ...
To use Stripe you must have SSL Certificate. First of all install it, and try again. If you still be a problem, contact our support. Our system administrator does not like to delve into the already existing systems, but I think he can give you advice.
 
#6
Thanks, I have SSL certificate the issue is that Stripe deprecated anything less than CentOS6.8 , I'm pretty sure I know how to update mine from 6.3 to 6.8 but don't know if i will kill all the data on my server in the process.

To use Stripe you must have SSL Certificate. First of all install it, and try again. If you still be a problem, contact our support. Our system administrator does not like to delve into the already existing systems, but I think he can give you advice.
 

Vitaly Kukin

Administrator
Staff member
#7
Thanks, I have SSL certificate the issue is that Stripe deprecated anything less than CentOS6.8 , I'm pretty sure I know how to update mine from 6.3 to 6.8 but don't know if i will kill all the data on my server in the process.
Anyway, I recommend contact to support. I talked with our system administrator, he promised to give advice. ;)
 
Top