Plugin could not be activated because it triggered a fatal error :(


New Member
I am trying to move from the normal plugin to the Woo version. What I've done was to delete all products, deactivate the old Alidropship plugin and activate the Woocommerce plugin, then the Ali Woo (correct php version 8.1).
Ali Woo does not activate, I've tried downloading it 2 times. The files in he zip file seem ok to me.
This is the error message displayed when trying to activate:

Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /var/www/html/wp-content/plugins/alidswoo/core/setup.php:0 Stack trace: #0 /var/www/html/wp-content/plugins/alidswoo/core/setup.php(0): adsw_install_options() #1 /var/www/html/wp-includes/class-wp-hook.php(308): adsw_install() #2 /var/www/html/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters() #3 /var/www/html/wp-includes/plugin.php(517): WP_Hook->do_action() #4 /var/www/html/wp-admin/plugins.php(194): do_action() #5 {main} thrown in /var/www/html/wp-content/plugins/alidswoo/core/setup.php on line 0

Any ideas?

I've tried to disable everything else, clear the cache etc. Nothing worked, Ali Wii just doesn't want to work. Ioncube is the same v as php, 8.1, and for some reason activating the stand alone Ali works. Only Ali woo not
Last edited: