Email notification not working

mushrukh

Member
Hi I just tested my website and after purchasing the order email doesn`t go to the customer but it`s copy does come to my email. what can be the reason???
@Yaros
 

Real Residual

Active Member
What service do you use? I use SparkPost free account and there is never an issue. As a matter of fact, emails get delivered to the inbox and not the spam folder because they are marked as "transactional" emails.
 

mushrukh

Member
What service do you use? I use SparkPost free account and there is never an issue. As a matter of fact, emails get delivered to the inbox and not the spam folder because they are marked as "transactional" emails.
Currently i am using mailgun .. but I am shifting to pepipost as their free account offers 25000 mails per month whichis maximum from any service provider.. am getting the mail of order purchase on my email id which provided for copy to send. But the customer is not getting it.
@Yaros @Victoria Kudryashova any help?? Or anything i am missing?
 

Victoria Kudryashova

Administrator
Staff member
Currently i am using mailgun .. but I am shifting to pepipost as their free account offers 25000 mails per month whichis maximum from any service provider.. am getting the mail of order purchase on my email id which provided for copy to send. But the customer is not getting it.
@Yaros @Victoria Kudryashova any help?? Or anything i am missing?
Could you please PM me your domain name and WP login credentials - I will check it out.
 

Ryan

Active Member
Hey, didn't want to make a new thread, will type here! @Yaros @Victoria Kudryashova

I am using MailGun service and haven't had any issues during last 14 months I am using it. But have one today. Worked well this morning but for the latest order which was made 3 hours ago, I haven't received e-mail. Also checked with Mailgun - no e-mails sent. Tried to test it, and test notification works fine. Also, tried to change new order status to Processed and then back to Paid - no changes, no e-mails sent.
Not a big issue, will see if it works with next purchase, just wanted to know any tips what could be the issue here?
 

Ryan

Active Member
Little update! Made one order as Shipped and e-mails were sent. So the issue is only with that one particular order.
 

Victoria Kudryashova

Administrator
Staff member
Hey, didn't want to make a new thread, will type here! @Yaros @Victoria Kudryashova

I am using MailGun service and haven't had any issues during last 14 months I am using it. But have one today. Worked well this morning but for the latest order which was made 3 hours ago, I haven't received e-mail. Also checked with Mailgun - no e-mails sent. Tried to test it, and test notification works fine. Also, tried to change new order status to Processed and then back to Paid - no changes, no e-mails sent.
Not a big issue, will see if it works with next purchase, just wanted to know any tips what could be the issue here?
Must be some delay or technical deficiency. Have you contacted MailGun also?
 
Top