PHP version error when update the plugin tu 1.6

#1
Hello,

I am getting the error when i added the updated version and change my PHP version from 5.6 to 7.1, but site stop working, like i cannot access the site backend. You can see the screen shot as well below. Please advise what should i need to do?

1554205630292.png
 

Mar

Moderator
#2
I am getting the error when i added the updated version and change my PHP version from 5.6 to 7.1, but site stop working, like i cannot access the site backend. You can see the screen shot as well below. Please advise what should i need to do?
If you mean updated version of the plugin and change PHP version. If you are sure the plugin is compatible with the PHP version you have set and you get this error, ask help from your host provider. It is the best way since it is easy in some, not so easy in some.
 

Direct Webstore

Well-Known Member
#3
Please advise what should i need to do?
Access the /wp-content/plugins/alids folder via FTP or cPanel>File Manager and rename it to alids-old. Then your site will work and you can delete the plugin and install the correct one.

Make sure the PHP version in cPanel is set to 7.1 and that the Alidropship plugin is 7.1

Or ... as Mar said above, contact you host to help you out if that is too difficult.

:)
 

Mar

Moderator
#4
I saw a lot of users having problems transitioning their site to another PHP version. I can do it easily at my end, but I cannot tell since I know it is not the same. When my host provider was Siteground, I cannot set PHP version myself in cPanel. There is no such setting in their cPanel, I am not sure now but during that time there was not. But I am really wondering why it look like many hesitate to ask help from their host provider and prefer to post the issue in the forum and receive different responses.
 
#5
I tried every thing, installed both version separately. contacted hosting provider and they said PHP version 7.1 is ionCube loader enable but when i activated it site showing HTTP 500 error and when i changed the other version then site performing good but PHP version not supported. I stucked in this from last 3 weeks :(
 

Mar

Moderator
#6
I tried every thing, installed both version separately. contacted hosting provider and they said PHP version 7.1 is ionCube loader enable but when i activated it site showing HTTP 500 error and when i changed the other version then site performing good but PHP version not supported. I stucked in this from last 3 weeks :(
I saw this response from host providers many times. They tend to take the easy way out. Don't just accept it, you get in touch with them and argue, it is their responsibility. Your stucked in this from last 3 weeks? if you just take their words, you will be stucked in it forever.
 
#7
I think i am not as technical as you? I can change the PHP version but site stop working, what should i need to tell them to do?
 

Mar

Moderator
#8
I think i am not as technical as you? I can change the PHP version but site stop working, what should i need to tell them to do?
You are not technical, that is why you need help and that help is not here in the forum. Get in touch with your host provider and tell them the problems you are facing and don't just accept whatever they say that don't help. You have to argue, that is their responsibility.
 
#9
They are telling plugin causing the issue. Disable the plugin and your site start working again.

EDIT: I did this, deleted the plugin from Cpanel and site working again. :|
 
Last edited:

Direct Webstore

Well-Known Member
#10
I did this, deleted the plugin from Cpanel and site working again. :|
That's more or less what I told you to do here.....
Access the /wp-content/plugins/alids folder via FTP or cPanel>File Manager and rename it to alids-old. Then your site will work and you can delete the plugin and install the correct one.
But are you sure you are installing the correct PHP version of the plugin?
 

Mar

Moderator
#11
They are telling plugin causing the issue. Disable the plugin and your site start working again.

EDIT: I did this, deleted the plugin from Cpanel and site working again. :|
You mean Aliropship plugin? So what will happen with the site now without it? I have so much of that statements from host providers. Again do not agree with what they say if it don't help. If the problem is the plugin, there is no Alidropship site now.
 
Top