ANY HELP DOWN SITE

Andre M

Active Member
#1
hi, i automatic update plugin but this update for version php7.2 but i have 7.1.
i decide to change all to 7.2
now show me this error on the plugin
An error of type E_ERROR was caused in line 0 of the file /home/ubershop/public_html/wp-content/plugins/alids/includes/ads/Helper.php. Error message: Uncaught Error: Call to undefined function ads\mb_strpos() in /home/ubershop/public_html/wp-content/plugins/alids/includes/ads/Helper.php:0 Stack trace: #0 /home/ubershop/public_html/wp-content/plugins/alids/core/init.php(0): ads\Helper::productUrl('https://www.ali...', '32850105924') #1 /home/ubershop/public_html/wp-includes/class-wp-hook.php(286): ads_view_on_ali(Array, Object(WP_Post)) #2 /home/ubershop/public_html/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #3 /home/ubershop/public_html/wp-admin/includes/class-wp-posts-list-table.php(1437): apply_filters('post_row_action...', Array, Object(WP_Post)) #4 /home/ubershop/public_html/wp-admin/includes/class-wp-posts-list-table.php(950): WP_Posts_List_Table->handle_row_actions(Object(WP_Post), 'title', 'title') #5 /home/ubershop/public_html/wp-admin/includes/class-wp-list-table.php(1323): WP_Posts_List_Table->_column_title(Object(WP_Post), 'title column-ti...', 'data-colname="T...', 'title') #6 /home/ubershop/public_html/wp-admin/includes/

And my product list have gone ; https://prnt.sc/o6jis9

can any one help me
 

Irene

Moderator
Staff member
#4
hi, i automatic update plugin but this update for version php7.2 but i have 7.1.
i decide to change all to 7.2
now show me this error on the plugin
An error of type E_ERROR was caused in line 0 of the file /home/ubershop/public_html/wp-content/plugins/alids/includes/ads/Helper.php. Error message: Uncaught Error: Call to undefined function ads\mb_strpos() in /home/ubershop/public_html/wp-content/plugins/alids/includes/ads/Helper.php:0 Stack trace: #0 /home/ubershop/public_html/wp-content/plugins/alids/core/init.php(0): ads\Helper::productUrl('https://www.ali...', '32850105924') #1 /home/ubershop/public_html/wp-includes/class-wp-hook.php(286): ads_view_on_ali(Array, Object(WP_Post)) #2 /home/ubershop/public_html/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #3 /home/ubershop/public_html/wp-admin/includes/class-wp-posts-list-table.php(1437): apply_filters('post_row_action...', Array, Object(WP_Post)) #4 /home/ubershop/public_html/wp-admin/includes/class-wp-posts-list-table.php(950): WP_Posts_List_Table->handle_row_actions(Object(WP_Post), 'title', 'title') #5 /home/ubershop/public_html/wp-admin/includes/class-wp-list-table.php(1323): WP_Posts_List_Table->_column_title(Object(WP_Post), 'title column-ti...', 'data-colname="T...', 'title') #6 /home/ubershop/public_html/wp-admin/includes/

And my product list have gone ; https://prnt.sc/o6jis9

can any one help me
Hello, Andre!

Have you deleted the plugin before upgrading your php version?

Please check our guide and ensure you have done everything according to it > https://help.alidropship.com/en/art...lugin-add-ons-php-5-6-7-0-support-termination.
 
#5
I had same problem Installing mbstring solve my problem
STEP 1 - Installing mbstring
PHP mbstring extension is not enabled by default as stated in PHP docs. Try these:
PHP 5:
sudo apt-get install php5-mbstring

PHP 7:
sudo apt-get install php7.0-mbstring

Now you should see mbstring as enabled in a file with below code (check above FelixEve's answer):
<?php echo phpinfo(); ?>

You might need to use the right extension name for your PHP version:
For example:
  • for PHP 5.6: sudo apt-get install php5.6-mbstring
  • for PHP 7.1: sudo apt-get install php7.1-mbstring
STEP 2 - Restart you server:
After the installation of mbstring, you may need to restart your server (apache2 / nginx etc). Just use the following command.
sudo service apache2 restart
or
sudo service nginx restart

https://stackoverflow.com/questions...all-php-mbstring-extension-in-to-nginx-ubuntu
 

Andre M

Active Member
#6
I had same problem Installing mbstring solve my problem
STEP 1 - Installing mbstring
PHP mbstring extension is not enabled by default as stated in PHP docs. Try these:
PHP 5:
sudo apt-get install php5-mbstring

PHP 7:
sudo apt-get install php7.0-mbstring

Now you should see mbstring as enabled in a file with below code (check above FelixEve's answer):
<?php echo phpinfo(); ?>

You might need to use the right extension name for your PHP version:
For example:
  • for PHP 5.6: sudo apt-get install php5.6-mbstring
  • for PHP 7.1: sudo apt-get install php7.1-mbstring
STEP 2 - Restart you server:
After the installation of mbstring, you may need to restart your server (apache2 / nginx etc). Just use the following command.
sudo service apache2 restart
or
sudo service nginx restart

https://stackoverflow.com/questions...all-php-mbstring-extension-in-to-nginx-ubuntu
Its all fixed tanks
 
Top